This Data Transfer Issue is a Head Scratcher

I’ve been facing a very unusual issue when transferring data to and from external hard drive docks and enclosures. It’s been happening for months now, with no plausible reason, or solution.

Regardless of computer or hard drive in each external enclosure, Windows 10 will only transfer data in “spurts”, For example: 130 Mbps for 1 minute at a time or longer, then falls to 0kbps, then randomly seconds or minutes later, back up to 130Mbps or higher, then down to 0kbps, and that pattern continues repeatedly. Sometimes I even need to turn off the enclosure, wait 10 seconds, and turn it back on, and resume the transfer, which continues to occur in the same rhythm. Very odd, but I’m not really in a rush to transfer the data, so it’s fine, and I’m happy it’s at least transferring.

When I use an external hard drive dock (have tried a few), I’m able to transfer data from any of my regular hard drives, regardless of hard drive dock used, to either of my desktop computers, or laptop, with no problem. But when I try to transfer data from any of my computers to any hard drive I put in my docks, every time it works for a few seconds, then the transfer rate drops to 0.0kbps, and the Windows dialog box just says it’s “calculating”, but when using a hard drive dock, the transfer rate does NOT increase and decrease in the pattern described above. After several minutes of clearly doing nothing, and I have to stop the transfer or end the task in Task Manager.

The issue doesn’t seem to be isolated to any particular hard drives, docks, or Windows 10, though to be fair, I don’t use any other operating system, so I can’t test others.

I contacted Memory Express, who I’ve known and trusted for years, and bought all 3 of my computers from, and they’re as baffled as I am about this issue, and claim it’s the first time they’ve heard of it.

So, I guess I’ll live with it for the foreseeable future until future online research miraculously provides some sort of solution.

Do you have any thoughts or possible solutions I can try? Please contact me. 🙂